Red Hat, Satellite

Satellite 6.2 error on update install or remove – /usr/share/ruby/tmpdir.rb:85:in `mkdir’: No such file or directory – /etc/katello-installer

Recently on a restore I got the following error for Satellite 6.2:

/usr/share/ruby/tmpdir.rb:85:in `mkdir’: No such file or directory – /etc/katello-installer/d20171010-14589-12we0i0 (Errno::ENOENT)

        from /usr/share/ruby/tmpdir.rb:85:in `block in mktmpdir’

        from /usr/share/ruby/tmpdir.rb:142:in `create’

        from /usr/share/ruby/tmpdir.rb:85:in `mktmpdir’

        from /usr/share/gems/gems/kafo-0.7.6.1/lib/kafo/configuration.rb:139:in `params_default_values’

        from /usr/share/gems/gems/kafo-0.7.6.1/lib/kafo/configuration.rb:194:in `block in preset_defaults_from_puppet’

        from /usr/share/gems/gems/kafo-0.7.6.1/lib/kafo/configuration.rb:193:in `each’

        from /usr/share/gems/gems/kafo-0.7.6.1/lib/kafo/configuration.rb:193:in `preset_defaults_from_puppet’

        from /usr/share/gems/gems/kafo-0.7.6.1/lib/kafo/kafo_configure.rb:251:in `set_parameters’

        from /usr/share/gems/gems/kafo-0.7.6.1/lib/kafo/kafo_configure.rb:97:in `initialize’

        from /usr/share/gems/gems/clamp-0.6.2/lib/clamp/command.rb:125:in `new’

        from /usr/share/gems/gems/clamp-0.6.2/lib/clamp/command.rb:125:in `run’

        from /usr/share/gems/gems/kafo-0.7.6.1/lib/kafo/kafo_configure.rb:148:in `run’

        from /usr/sbin/satellite-installer:12:in `<main>’

Thankfully I wasn’t the first one and it looks like this was an oversight when you have 6.1 and upgrade to 6.2 – https://bugzilla.redhat.com/show_bug.cgi?id=1422905

Apparently the directory for the answers was changed from /etc/katello-installer to /etc/foreman-installer/scenarios.d

The fix is rather simple, all you need to do is edit the /etc/foreman-installer/scenarios.d/satellite.yaml and modify the following line to what is shown below

  :default_values_dir: /etc/foreman-installer/scenarios.d

After that, no more errors.  The community is fixing this upstream and it should be a non-issue soon enough but if you hit this error, this is the fix.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s